nanoをインストールしようとして"Insufficient UTF-8 support was detected in your curses and/or C libraries"

Ubuntu 9.04で最新版のGNU nano (http://www.nano-editor.org/dist/v2.2/nano-2.2.6.tar.gz) をインストールしようとしたら、configureで警告が出ました。
*** Insufficient UTF-8 support was detected in your curses and/or C
*** libraries.  If you want UTF-8 support, please verify that your slang
*** was built with UTF-8 support or your curses was built with wide
*** character support, and that your C library was built with wide
*** character support.

原因と対処法

"libncursesw"というライブラリが必要なようです。
apt-get install libncursesw5-dev
で解決しました。
カテゴリ:

人気記事