[Perl][CPAN]Web::Scraperのインストールがうまくできない。。。

Ubuntu9.04にWeb::Scraperをインストールしたかったのですが、うまくいきません。

私はPerlが大好きなのですが、CPANモジュールのインストールができないときは何をどうしてよいのかわからず途方にくれてしまいます。

う~ん。。。モダンPerlへの道は険しい。。。

cpan > install Web::Scraper

Test Summary Report
-------------------
t/xml-simple.t        (Wstat: 512 Tests: 0 Failed: 0)
  Non-zero exit status: 2
  Parse errors: No plan found in TAP output
Files=22, Tests=40,  9 wallclock secs ( 0.72 usr  0.18 sys +  6.39 cusr  1.73 csys =  9.02 CPU)
Result: FAIL
Failed 1/22 test programs. 0/40 subtests failed.
make: *** [test_dynamic] Error 2
  MIYAGAWA/Web-Scraper-0.32.tar.gz
  /usr/bin/make test -- NOT OK
//hint// to see the cpan-testers results for installing this module, try:

  reports MIYAGAWA/Web-Scraper-0.32.tar.gz
Running make install
  make test had returned bad status, won't install without force
Failed during this command:
 MIYAGAWA/HTML-TreeBuilder-LibXML-0.11.tar.gz : make_test NO
 MIYAGAWA/Web-Scraper-0.32.tar.gz             : make_test NO

HTML::TreeBuilder::LibXMLのインストールが失敗したのかな?

cpan > install HTML::TreeBuilder::LibXML

中略

t/HTML-TreeBuilder-XPath.t .. 1/19 Can't locate XML/LibXML.pm
 in @INC (@INC contains:
 /root/.cpan/build/HTML-TreeBuilder-LibXML-0.11-sa80fu/inc
 /root/.cpan/build/HTML-TreeBuilder-LibXML-0.11-sa80fu/blib/lib
 /root/.cpan/build/HTML-TreeBuilder-LibXML-0.11-sa80fu/blib/arch
 /etc/perl /usr/local/lib/perl/5.10.0 /usr/local/share/perl/5.10.0
 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 
 /usr/local/lib/site_perl .) 
at /root/.cpan/build/HTML-TreeBuilder-LibXML-0.11-sa80fu/blib/lib/HTML/TreeBuilder/LibXML.pm line 7.

中略

Result: FAIL
Failed 7/7 test programs. 1/2 subtests failed.
make: *** [test_dynamic] Error 2
  MIYAGAWA/HTML-TreeBuilder-LibXML-0.11.tar.gz
  /usr/bin/make test -- NOT OK

XML::LibXMLのインストールが失敗してるのかな?

cpan[1]> install XML::LibXML
CPAN: Storable loaded ok (v2.18)
Going to read '/root/.cpan/Metadata'
  Database was generated on Sat, 05 Jun 2010 04:27:23 GMT
CPAN: YAML loaded ok (v0.70)
Going to read 86 yaml files from /root/.cpan/build/
CPAN: Time::HiRes loaded ok (v1.9711)
DONE
Restored the state of none (in 2.0500 secs)
Running install for module 'XML::LibXML'
Running make for P/PA/PAJAS/XML-LibXML-1.70.tar.gz
  Has already been unwrapped into directory /root/.cpan/build/XML-LibXML-1.70-IIX0Tb
  No 'Makefile' created
, won't make
Running make test
  Make had some problems, won't test
Running make install
  Make had some problems, won't install
うむむ。。。
まぁ失敗は成功の母ということで、何もしないよりは一歩前進した。

ググって調べてみます。
カテゴリ: